SVM Failed disk replacement on Solaris
1.Take backup below file output:-
a.metastat -p
b.metastat -t
c.metadb -i
d.echo|fromat
e.iostat -En
f.ifconfig -a
2.Identify the failed disk by following commands:-
#iostat -en
— - errors —
s/w h/w trn tot device
6 50 0 6 c1t2d0
#echo|format
Indentifying the logs(/var/adm/message) & dmesg
3.detach the failed disk submirror
#metadetach d0 d20
4.clear the submirror -->metaclear d20
5.delete the statedata base replica of failed disk
#metadb -d -f c1t2d0s3
6.Remove hard drive from the tree in the sequence
Incase the SCSI/SAS disk
#cfgadm -al--->c0::dsk/c1t2d0 disk connected configured unknown
#cfgadm -c unconfigure c0::dsk/c1t2d0)--->c1::dsk/c1t2d0 disk connected unconfigured unknown
#cfgadm -z remove_device c0::dsk/c1t2d0 (for data disk only)
In case of FCAL Sun 280R, V880, V490, V880, V890
command sequence to replace the disks
#luxadm -e port
#luxadm probe(to display paths)
#luxadm remove_device_F /dev/rdsk/c#t#d#s2
#devfsadm -v -Cc disk (where:C=cleans dir:c=specify disk)
#luxadm insert_device (optional)
7.Remove the disk from server
8.Insert the new disk
9.Configure the new disk
#cfgadm -c configure c1:dsk/c1t2d0
Verify the device connected in device tree.-->cfgadm -al
10.Check the status in server by applying:
#echo|format or #iostat -en
if not visible
#devfsadm -C -C disks
or
#devfsadm -c configure
11.Check the vtoc table for root disk and replaced disk if not same do below
prtvtoc /dev/rdsk/c1t2d1s2 |fmthard -s - /dev/rdsk/c1t2d0s2
12.create the statedata base on replaced disk
metadb -afc 3 /dev/dsk/c1t2d0s3
13.Reattach the mirror and wait until all mirrors will sycned
#metainit d2 1 1 c1t2d0s0
#metatttach d5 d2
#metastat -ac or metastat -t to check the sycning status
14.safe to run metadevadm command to update the new ID
#metadevadm -u
#metadevadm -u /dev/dsk/c1t2d0
1.Take backup below file output:-
a.metastat -p
b.metastat -t
c.metadb -i
d.echo|fromat
e.iostat -En
f.ifconfig -a
2.Identify the failed disk by following commands:-
#iostat -en
— - errors —
s/w h/w trn tot device
6 50 0 6 c1t2d0
#echo|format
Indentifying the logs(/var/adm/message) & dmesg
3.detach the failed disk submirror
#metadetach d0 d20
4.clear the submirror -->metaclear d20
5.delete the statedata base replica of failed disk
#metadb -d -f c1t2d0s3
6.Remove hard drive from the tree in the sequence
Incase the SCSI/SAS disk
#cfgadm -al--->c0::dsk/c1t2d0 disk connected configured unknown
#cfgadm -c unconfigure c0::dsk/c1t2d0)--->c1::dsk/c1t2d0 disk connected unconfigured unknown
#cfgadm -z remove_device c0::dsk/c1t2d0 (for data disk only)
In case of FCAL Sun 280R, V880, V490, V880, V890
command sequence to replace the disks
#luxadm -e port
#luxadm probe(to display paths)
#luxadm remove_device_F /dev/rdsk/c#t#d#s2
#devfsadm -v -Cc disk (where:C=cleans dir:c=specify disk)
#luxadm insert_device (optional)
7.Remove the disk from server
8.Insert the new disk
9.Configure the new disk
#cfgadm -c configure c1:dsk/c1t2d0
Verify the device connected in device tree.-->cfgadm -al
10.Check the status in server by applying:
#echo|format or #iostat -en
if not visible
#devfsadm -C -C disks
or
#devfsadm -c configure
11.Check the vtoc table for root disk and replaced disk if not same do below
prtvtoc /dev/rdsk/c1t2d1s2 |fmthard -s - /dev/rdsk/c1t2d0s2
12.create the statedata base on replaced disk
metadb -afc 3 /dev/dsk/c1t2d0s3
13.Reattach the mirror and wait until all mirrors will sycned
#metainit d2 1 1 c1t2d0s0
#metatttach d5 d2
#metastat -ac or metastat -t to check the sycning status
14.safe to run metadevadm command to update the new ID
#metadevadm -u
#metadevadm -u /dev/dsk/c1t2d0
No comments:
Post a Comment